通达信超级短线王异动指标公式无未起原码编程思路破译

发布日期:2022-09-08 21:52    点击次数:167

编程思路破译:

LC赋值:1日前的开盘价

超级短线王赋值:(((开盘价-LC)和0的较大值的5日[1日权重]移动匀称 / (开盘价-LC)的绝对于值的5日[1日权重]移动匀称) * 100)

异动指标公式赋值:(最低价-最自制)和(最低价-1日前的开盘价)的绝对于值的较大值和(最自制-1日前的开盘价)的绝对于值的较大值的10日累和

无未起原码赋值:(最低价 - 1日前的最低价)

通达信赋值:(1日前的最自制 - 最自制)

GGHYY1赋值:假定((无未起原码>0)AND(无未起原码>通达信)),前去无未起原码,否则前去0的10日累和

GGHYY2赋值:假定((通达信>0)AND(通达信>无未起原码)),前去通达信,否则前去0的10日累和

GGHYY3赋值:((GGHYY1 * 100) / 异动指标公式)

GGHYY4赋值:((GGHYY2 * 100) / 异动指标公式)

GGHYY5赋值:(((GGHYY4-GGHYY3)的绝对于值/(GGHYY4+GGHYY3))*100)的5日俭朴移动匀称

AV赋值:(超级短线王 + GGHYY5)

GGHYY6赋值:(((GGHYY5 + 5日前的GGHYY5) / 2) + 超级短线王)

GGHYY7赋值:((100 * (10日内最低价的最高值 - 开盘价)) / (10日内最低价的最高值 - 10日内最自制的最低值))

GGHYY8赋值:(超级短线王 - GGHYY7)

HHJJY1赋值:(AV + GGHYY8)

HHJJY1选股赋值:假定HHJJY1上穿0,前去1,否则前去0,STICK,画白色

XXSSS1赋值:HHJJY1选股的3日[1日权重]移动匀称

XXSSS2赋值:XXSSS1的3日[1日权重]移动匀称,COLOR0000FF

XXSSS3赋值:XXSSS2的3日[1日权重]移动匀称,COLOR00FFFF

输出HHJJY2:假定XXSSS2上穿XXSSS3AND(XXSSS2<40),前去5,否则前去0*10000,COLORFF00FF,线宽为2

顺序源码:

LC:=REF(CLOSE,1);

超级短线王:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);

异动指标公式:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);

无未起原码:=(HIGH - REF(HIGH,1));

通达信:=(REF(LOW,1) - LOW);

gghyy1:=SUM(IF(((无未起原码 > 0) AND (无未起原码 > 通达信)),无未起原码,0),10);

gghyy2:=SUM(IF(((通达信 > 0) AND (通达信 > 无未起原码)),通达信,0),10);

gghyy3:=((gghyy1 * 100) / 异动指标公式);

gghyy4:=((gghyy2 * 100) / 异动指标公式);

gghyy5:=MA(((ABS((gghyy4 - gghyy3)) / (gghyy4 + gghyy3)) * 100),5);

AV:=(超级短线王 + gghyy5);

gghyy6:=(((gghyy5 + REF(gghyy5,5)) / 2) + 超级短线王);

gghyy7:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));

gghyy8:=(超级短线王 - gghyy7);

hhjjy1:=(AV + gghyy8);

hhjjy1选股:=IF(CROSS(hhjjy1,0),1,0),STICK,COLORRED;

xxsss1:=SMA(hhjjy1选股,3,1);

xxsss2:=SMA(xxsss1,3,1),COLOR0000FF;

xxsss3:=SMA(xxsss2,3,1),COLOR00FFFF;

hhjjy2:IF(CROSS(xxsss2,xxsss3) AND (xxsss2<40),5,0* 10000),COLORFF00FF,LINETHICK2;

本站是供应集团知识打点的网络存储空间,全体内容均由用户宣布,不代表本站概念。请留心甄别内容中的联络要领、诱惑置办等信息,谨防诳骗。如缔造有害或侵权内容,请点击一键告发。


热点资讯

相关资讯



Powered by 【开元78ky官方认证】 @2013-2022 RSS地图 HTML地图